Ноутбук може отримати DHCP-адресу, але інші пристрої не можуть бути підключені до одного комутатора

В даний час у мене є 1x Juniper ex3300 і 1x HP ProCurve 2848, які утворюють ядро ​​моєї мережі, при цьому vlans 1, 10, 20 і 30 перебувають між собою в портах 46-47. Ex3300 діє як сервер DHCP для всіх онлайнов і маршрутів між ними та Інтернетом.

Бездротові ПП (аеропорт експрес/екстремальний) підключаються безпосередньо до кожного з цих вимикачів в більшості випадків, але в деяких, Mikrotik RB260gs підключаються через зовнішні зв'язки з тими ж самими лініями через них.

Прямі підключення ПП функціонують добре, а комутатори можуть бути розміщені в будь-якій VLAN і зберігати зв'язок. RB260gs функціонує правильно (він обслуговує DHCP-адреси, пов'язані з VLAN, повного з'єднання), коли мій ноутбук підключено. Коли я підключу будь-який інший пристрій до того ж порту, пристрій не отримує DHCP-адресу, і немає підключення

Я протестував це досі з Receiver Onkyo AV, Airport Extreme, Airport Express, котрий не збирають DHCP адресу. Два вікна машини підбирають DHCP (один з яких має лише чистий вікно, встановлене на нього).

Я тут нічого не маю. Хтось надає руку?

[UPDATE] - Configs Mikrotik VLAN Config

HP CONFIG

hostname "MUST-CSW2-HP2848"
mirror-port 39
interface 6
   name "Captains_Cabin_Express"
exit
interface 11
   name "VIP_AP"
exit
interface 20
   name "ASW1-Master"
exit
ip default-gateway 172.20.11.254
snmp-server community "public" Unrestricted
vlan 1
   name "DEFAULT_VLAN"
   ip address dhcp-bootp
   tagged 10
   no untagged 1-9,11-48
   exit
vlan 10
   name "Ship"
   untagged 1-19,21-38,40-44
   ip address 172.20.11.253 255.255.254.0
   tagged 20,45-48
   exit
vlan 20
   name "Crestron"
   ip address 172.20.20.253 255.255.255.0
   tagged 20,45-48
   exit
vlan 30
   name "Guest"
   untagged 39
   ip address 172.20.30.253 255.255.255.0
   tagged 20,45-48
   exit
vlan 99
   name "Management"
   exit
interface 20
   monitor
   exit
spanning-tree

CONFIG JUNIPER

****************output omitted**********************

        dhcp {
            traceoptions {
                file dhcp_logfile;
                level all;
                flag all;
            }
            pool 172.20.10.0/23 {
                address-range low 172.20.10.50 high 172.20.11.149;
                name-server {
                    8.8.8.8;
                    8.8.4.4;
                }
                router {
                    172.20.11.254;
                }
            }
            pool 172.20.30.0/24 {
                address-range low 172.20.30.25 high 172.20.30.225;
                name-server {
                    8.8.8.8;
                    8.8.4.4;
                }
                router {
                    172.20.30.254;
                }
            }
            pool 172.20.20.0/24 {
                address-range low 172.20.20.50 high 172.20.20.225;
                name-server {
                    8.8.8.8;
                    8.8.4.4;
                }
                router {
                    172.20.20.254;
                }
            }
        }
    }

****************output omitted*************************

    ge-0/0/44 {
        unit 0 {
            family ethernet-switching {
                port-mode trunk;
            }
        }
    }
    ge-0/0/45 {
        unit 0 {
            family ethernet-switching {
                port-mode trunk;
                vlan {
                    members [ Ship Guest Crestron-Control ];
            }
        }
    }
    ge-0/0/46 {
        unit 0 {
            family ethernet-switching {
                port-mode trunk;
                vlan {
                    members [ Ship Guest Crestron-Control ];
            }
        }
    }
    ge-0/0/47 {
        unit 0 {
            family ethernet-switching {
                port-mode trunk;
                vlan {
                    members [ Ship Guest Crestron-Control ];
                }
            }
        }

**************output omitted******************

    vlan {
        unit 0 {
            family inet;
        }
        unit 1 {
            family inet;
        }
        unit 10 {
            family inet {
                address 172.20.11.254/23;
            }
        }
        unit 20 {
            family inet {
                address 172.20.20.254/24;
            }
        }
        unit 30 {
            family inet {
                address 172.20.30.254/24;
            }
        }
        unit 100 {
            family inet {
                address 172.20.100.14/28;
            }
        }
    }
}

***************output omitted******************

routing-options {
    static {
        route 0.0.0.0/0 next-hop 172.20.100.1;
    }
}
protocols {
    igmp-snooping {
        vlan all;
    }
    rstp {
        bridge-priority 0;
    }
    lldp {
        interface all;
    }
    lldp-med {
        interface all;
    }
}
ethernet-switching-options {
    storm-control {
        interface all;
    }
}
vlans {
    Crestron-Control {
        description "Crestron Network Resources";
        vlan-id 20;
        interface {
            ge-0/0/47.0;
            ge-0/0/44.0;
            ge-0/0/45.0;
            ge-0/0/46.0;
        }
        l3-interface vlan.20;
    }
    Guest {
        description "Guest Network Resources and User Devices";
        vlan-id 30;
        interface {
            ge-0/0/47.0;
            ge-0/0/46.0;
            ge-0/0/45.0;
            ge-0/0/44.0;
            ge-0/0/10.0;
        }
        l3-interface vlan.30;
    }
    Internet_Connection {
        description "Connection to Peplink30 via Bridge_MAIN";
        vlan-id 100;
        interface {
            ge-0/0/0.0;
        }
        l3-interface vlan.100;
    }
    Management {
        vlan-id 99;
        l3-interface vlan.0;
    }
    Ship {
        description "Hardware and Crew";
        vlan-id 10;
        interface {
            ge-0/0/47.0;
            ge-0/0/11.0;
            ge-0/0/12.0;
            ge-0/0/13.0;
            ge-0/0/14.0;
            ge-0/0/15.0;
            ge-0/0/16.0;
            ge-0/0/17.0;
            ge-0/0/18.0;
            ge-0/0/19.0;
            ge-0/0/29.0;
            ge-0/0/44.0;
            ge-0/0/45.0;
            ge-0/0/46.0;
        }
        l3-interface vlan.10;
    }
    default {
        vlan-id 1;
        interface {
            ge-0/0/47.0;
        }
        l3-interface vlan.1;
    }
}
poe {
    interface all;
}
0
Це може допомогти показати конфігурацію вашого Juniper.
додано Автор SitWalkStand, джерело
Чи допомогла вам будь-яка відповідь? Якщо це так, ви повинні прийняти відповідь, щоб питання не виникало вічно, шукаючи відповідь. Крім того, ви можете надати і прийняти власну відповідь.
додано Автор Ron Maupin, джерело
Звичайно, хоча я не думаю, що це конфігурація ялівцю, тому що я можу безпосередньо (або через HP) підключити точку доступу до будь-якої мережі VLAN і отримати правильну пропозицію DHCP. Я впевнений, що це конфіденційна проблема з Mikrotik (конфігурація також опублікована) або з'єднання Mikrotik-HP.
додано Автор MikeJ-UK, джерело
також, будь ласка, дайте мені знати, якщо ви хочете повну конфігурацію. Я новачок в платах і не знаю, що вважається спамом.
додано Автор MikeJ-UK, джерело

1 Відповіді

Якщо мережі спрямовуються через вашу HP (не маєте з'єднання Layer2, перебуваючи у тій самій VLAN, що і їх DHCP-сервер), вам слід додати IP-помічника, щоб дозволити DHCP Broadcasts перейти на відповідний сервер DHCP.

Для вас інтерфейс-конфігурація на може виглядати так, то:

vlan 30
   name "Guest"
   untagged 39
   ip address 172.20.30.253 255.255.255.0
   ip helper-address x.x.x.x (IP Address of DHCP Server)
   tagged 20,45-48
exit
2
додано